Firewall Push Security Events

Secure Access KeyTypeDescription
specversionstringThe version of the Push Security Event schema.
typestringThe type of the security event.
sourcestringThe unique label that describes the source of the security event.
orgidintegerThe unique identifier of the organization.
integrationidstringThe unique identifier of the integration.
idstringThe unique identifier for the push security event.
timestringThe date and time when the system sent the event. The system formats the timestamp in the ISO 8601 format.
datacontenttypestringThe type of the content in the push security event.
dataobjectThe properties of the data for the push security events.

data

Secure Access KeyTypeDescription
eventsarrayThe list of push security event messages.

data.events

Secure Access KeyOCSF KeyTypeDescription
activity_idintegerThe unique identifier of the activity that triggered the security event.
category_uidintegerThe unique identifier of the security event category.
cisco_event_idEvent IDstringThe unique identifier of the security event.
cisco_event_typestringThe type of the security event.
cisco_organization_idOrganization IDnumberThe unique identifier of the organization.
class_uidintegerThe unique identifier of the class.
cisco_fw_metadataobjectThe properties of the metadata for the Cisco firewall.
cisco_originobjectThe properties of the origin.
cisco_other_originsarrayThe list of the other origins.
cloudobjectThe properties of the cloud deployment.
connection_infoobjectThe properties of the client connection information.
dst_endpointobjectThe properties of the destination.
metadataobjectThe metadata for the security event.
policyobjectThe properties of the components and profiles for the access rules in the Access policy.
src_endpointobjectThe properties of the client endpoint.
severity_idnumberThe identifier of the severity.
timeTimestringThe date and time when the system recorded the security event. The system formats the timestamp in milliseconds since the Unix Epoch.
type_uidintegerThe identifier of the type for the security event.
urlobjectThe properties of the URL.

data.events.cisco_fw_metadata

Secure Access KeyOCSF KeyTypeDescription
app_idApp IDnumberThe identifier of the application.
app_protocol_idApp Protocol IDnumberThe identifier of the application protocol.
bytes_receivedBytes ReceivednumberThe number of bytes received by the application.
bytes_sentBytes SentnumberThe number of bytes sent by the application.
client_application_idClient Application IDstringThe identifier of the client application.
client_versionClient VersionstringThe version of the client application.
config_maskConfig MasknumberThe hash of the configuration.
directionDirectionstringThe label that describes the direction of the traffic flow.
dns_queryDNS QuerystringThe DNS query sent by the client system.
egress_ipEgress IPstringThe IPv4 or IPv6 address that support the egress of traffic from the client system.
fw_event_idFW Event IDstringThe unique identifier of the firewall event.
http_response_codeHTTP Response CodenumberThe HTTP response code of the firewall event.
is_reserved_ipIs Reserved IPbooleanSpecifies whether the IP is reserved for the organization.
match_maskMatch MasknumberThe hash of the traffic that matches the signature.
packet_sizePacket SizenumberThe size of the packet (network traffic).
packets_receivedPackets ReceivednumberThe number of packets received by the firewall.
packets_sentPackets SentnumberThe number of packet sent by the firewall.
referenced_hostReferenced HoststringThe hostname referenced in the network traffic.
tcp_flag_bitsTCP Flag BitsnumberThe flag bits set on the TCP message.
traffic_sourceTraffic SourcestringThe hostname associated with the traffic source.
user_agentUser AgentstringThe label for the user agent associated wit the network traffic.

data.events.cisco_origin

Secure Access KeyOCSF KeyTypeDescription
idOrigin IDintegerThe unique identifier of the endpoint.
typeOrigin TypestringThe type of the endpoint, for example: network, ad computer.

data.events.cisco_other_origins

Secure Access KeyOCSF KeyTypeDescription
idOrigin IDintegerThe unique identifier of the endpoint.
typeOrigin TypestringThe type of the endpoint.

data.events.cloud

Secure Access KeyOCSF KeyTypeDescription
regionAWS RegionstringThe region where the system deployed the firewall service.

data.events.connection_info

Secure Access KeyOCSF KeyTypeDescription
direction_idnumberThe numeric identifier of the direction.
protocol_numIP ProtocolnumberThe numeric identifier of the protocol.
uidConnection IDstringThe unique identifier of the connection.

data.events.dst_endpoint

Secure Access KeyOCSF KeyTypeDescription
ipDestination IPstringThe IPv4 or IPv6 addresses associated with the destination.
locationDestination CountryobjectThe regional information associated with the destination.
namestringThe hostname of the destination.
portDestination PortnumberThe number of the port associated with the destination.

data.events.dst_endpoint.location

Secure Access KeyOCSF KeyTypeDescription
countryDestination CountrystringThe two-character country code associated with the destination.

data.events.metadata

Secure Access KeyOCSF KeyTypeDescription
productobjectThe properties of the product.
versionstringThe version of the product.

data.events.metadata.product

Secure Access KeyOCSF KeyTypeDescription
namestringThe name of the product.

data.events.policy

Secure Access KeyOCSF KeyTypeDescription
dataContent Category IDsobjectThe properties of the data in the organization's Access policy.
uidRule IDintegerThe unique identifier of the access rule in the Access policy that matches the network traffic.
verdictVerdictstringThe label of the verdict assigned to the destination.

data.events.policy.data

Secure Access KeyOCSF KeyTypeDescription
casi_category_idsCASI Category IDsarray(string)The identifier of the security category.
content_category_idsContent Category IDsarray(string)The identifier of the content category.
content_category_list_idsContent Category List IDsarray(string)The identifier of the content category list.
destination_listsDestination List IDarray(string)The identifier of the destination list.
fw_block_reasonFW Block ReasonstringThe description of why the system blocked the network traffic.
policy_revisionPolicy RevisionstringThe label associated with the revision of the policy.
posture_idPosture IDstringThe identifier of the posture.
private_app_idPrivate App IDstringThe identifier of the private application.
private_flowPrivate FlowbooleanSpecifies whether the traffic flow is to a private destination.

data.events.src_endpoint

Secure Access KeyOCSF KeyTypeDescription
ipSource IPstringThe public IPv4 or IPv6 address of the client endpoint seen by the DNS resolver.
namestringThe hostname of the client endpoint.
portSource PortnumberThe number of the port associated with the client endpoint.

data.events.url

Secure Access KeyOCSF KeyTypeDescription
url_stringURLstringThe URL of the destination.