IPS Push Security Events

Secure Access KeyTypeDescription
specversionstringThe version of the Push Security Event schema.
typestringThe type of the security event.
sourcestringThe unique label that describes the source of the security event.
orgidintegerThe unique identifier of the organization.
integrationidstringThe unique identifier of the integration.
idstringThe unique identifier for the push security event.
timestringThe date and time when the system sent the event. The system formats the timestamp in the ISO 8601 format.
datacontenttypestringThe type of the content in the push security event.
dataobjectThe properties of the data for the push security events.

data

Secure Access KeyTypeDescription
eventsarrayThe list of push security event messages.

data.events

Secure Access KeyOCSF KeyTypeDescription
activity_idintegerThe unique identifier of the activity that triggered the security event.
category_uidintegerThe unique identifier of the security event category.
cisco_event_idEvent IDstringThe unique identifier of the security event.
cisco_event_typestringThe type of the security event.
cisco_organization_idOrganization IDnumberThe unique identifier of the organization.
cisco_ips_metadataobjectThe properties of the Cisco IPS metadata.
cisco_originobjectThe properties of the origin.
class_uidintegerThe unique identifier of the class.
cloudobjectThe properties of the cloud deployment.
connection_infoobjectThe properties of the client connection information.
dst_endpointobjectThe properties of the destination.
firewall_ruleobjectThe properties of the access rule for the firewall.
metadataobjectThe metadata for the security event.
policyobjectThe properties of the components and profiles for the access rules in the Access policy.
severity_idnumberThe unique identifier of the severity.
src_endpointobjectThe properties of the client endpoint.
timeTimestringThe date and time when the system recorded the security event. The system formats the timestamp in milliseconds since the Unix Epoch.
type_uidintegerThe identifier of the type for the security event.
urlobjectThe properties of the URL.

data.events.cisco_ips_metadata

Secure Access KeyOCSF KeyTypeDescription
actionActionstringThe label that describes the action taken by the system for the network traffic.
attack_classificationAttack ClassificationstringThe type of attack associated with the network traffic.
correlation_uidstringThe unique identifier of the correlation.
directionDirectionstringThe direction of the traffic flow.
egress_ipEgress IPstringThe IPv4 or IPv6 address associated with the egress of the traffic from the client system.
enforcement_pointEnforcement PointstringThe description of the point of enforcement.
ftd_enforcement_idFTD Enforcement IDnumberThe identifier of the Cisco Firepower Threat Defense (FTD) device.
ftd_enforcement_nameFTD Enforcement NamestringThe name of the Cisco Firepower Threat Defense (FTD) device.
fw_event_idFW Event IDstringThe identifier of the firewall event.
is_reserved_ipIs Reserved IPbooleanSpecifies whether the IP is reserved for the organization.
operation_modeOperation ModestringThe description of the operation mode.
snort_generator_idSnort Generator IDnumberThe identifier of the snort generator associated with the event.
snort_signature_idSnort Signature IDnumberThe identifier of the snort signature associated with the event.

data.events.cisco_origin

Secure Access KeyOCSF KeyTypeDescription
idOrigin IDintegerThe unique identifier of the endpoint.
typeOrigin TypestringThe type of the endpoint, for example: network, ad computer.

data.events.cloud

Secure Access KeyOCSF KeyTypeDescription
regionAWS RegionstringThe region where the system deployed the cloud firewall service.

data.events.connection_info

Secure Access KeyOCSF KeyTypeDescription
direction_idnumberThe numeric identifier of the direction.
protocol_numIP ProtocolnumberThe numeric identifier of the protocol.

data.events.dst_endpoint

Secure Access KeyOCSF KeyTypeDescription
ipstringThe IPv4 or IPv6 addresses associated with the destination.
namestringThe hostname of the destination.

data.events.firewall_rule

Secure Access KeyOCSF KeyTypeDescription
uidFirewall Rule IDstringThe unique identifier of the access rule.

data.events.metadata

Secure Access KeyOCSF KeyTypeDescription
productobjectThe properties of the product.
versionstringThe version of the product.

data.events.metadata.product

Secure Access KeyOCSF KeyTypeDescription
namestringThe name of the product.

data.events.policy

Secure Access KeyOCSF KeyTypeDescription
dataobjectThe properties of the data in the organization's Access policy.

data.events.policy.data

Secure Access KeyOCSF KeyTypeDescription
ips_config_typeIPS Config TypestringThe type of the IPS configuration.
ips_resource_idPolicy Resource IDnumberThe identifier of the IPS profile.
priorityPrioritystringThe priority that the system assigned to the IPS profile.

data.events.src_endpoint

Secure Access KeyOCSF KeyTypeDescription
ipSource IPstringThe public IPv4 or IPv6 address of the client endpoint.
namestringThe hostname of the client endpoint.
portSource PortnumberThe number of the port associated with the client endpoint.

data.events.url

Secure Access KeyOCSF KeyTypeDescription
url_stringURLstringThe URL of the destination.