CGR 1000 Compute Module

The CGR Compute Module is a modular, hardened server that can be installed in CGR 1000 routers. The compute module functions as a fog computing node at the edge of the network. See the following documents for more information about the compute module:

Note: In this and the above documents, the Compute Module is identified as a server module in Cisco IOS commands.

IOS Image

The minimum IOS version required for IOx support is 15.6(3)M2.

IOx Image

IOx functionality is part of the server module image. The minimum server module image version is 1.2.5.1.

Note: The server module image is NOT part of the CGR bundle image.

Getting Full Bandwidth to Your IOx App

Local Manager View

Do not use the router’s virtual interface svcbr_0 -- GigabitEthernet/2 for anything other than low bandwidth management traffic. This interface is an emulated Ethernet via an internal shared USB that has a throughput of 4 Mbps and an MTU of 1492.

Instead, use the CGM-SRV-64 or CGM-SRV-128 external physical port with a cable that is plugged back into one of the Gigabit Ethernet ports on the CGR.

Physical Cabling

Physical Cabling

Interfaces

The server module has the following internal and external interfaces:

  • Internal Interfaces

    • console: virtual console line to the server module’s Host-OS
    • interface management interface: interface GigabitEthernet<slot#>/1 providing networking connectivity for IOx host
    • internal interface to application: interface GigabitEthernet<slot#>/2 providing networking connectivity for IOx applications

    Note: When sending traffic over the internal gig {slot}/2 interface, from the application to IOS or the external machine, we are rate-limited to 4 Mbps. For higher traffic, the external interface on the server module is the recommended option.

    In addition, the MTU Setting must be 1492 on both sender and receiver interfaces. The MTU setting on the Server module interface can scale only to 1492 and does not support path discovery. If the external machine supports MTU path discovery, you can configure the CGR1000 gig{slot}/2 interface MTU to 1492, since IOS supports the feature. Using the above settings ensures fragmentation for any packet size will work.

  • External Interfaces

    • front panel RJ45 Gigabit Ethernet Interface: providing IOx applications direct access to the external network
    • USB0 and USB1: two USB2.0 ports. You can connect an external USB flash drive for extra storage. These ports cannot be used as power sources.

Compute Module Front Panel

Compute Module

Basic IOS and IOx Configuration

Configuring Networking for IOx Host

interface GigabitEthernet4/1
 ip address 192.168.3.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 duplex auto
 speed auto
 ipv6 enable
!

Configuring Local DHCP Pool for Server Module Host IP Address Assignment

To assign an IP address to an IOx host, configure a Local DHCP pool on IOS with interface GigabitEthernet<slot#>/1 as the default router.

ip dhcp pool smpool
 network 192.168.3.0 255.255.255.252
 default-router 192.168.3.1
 dns-server 171.70.168.183 173.36.131.10
 lease infinite
!

Note: NAT rule to be configured for IOx host must be reachable from outside.

Configuring Networking for IOx Apps

interface GigabitEthernet4/2
 ip address 192.168.4.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 duplex auto
 speed auto
 ipv6 enable
!

Configuring Local DHCP Pool for IOx Apps

To assign an IP address to IOx Apps, configure a Local DHCP pool on IOS with interface GigabitEthernet<slot#>/2 as the default router.

ip dhcp pool vmpool
 network 192.168.4.0 255.255.255.252
 default-router 192.168.4.1
 dns-server 171.70.168.183 173.36.131.10
 lease infinite
!

Note: The applications can also connect to the outside via the front panel Ethernet port on the server module.

Configure NTP server for the router

Note: The Guest OS VM periodically compares its time with the Cisco IOS time. If the difference in times is more than 60 seconds, the Guest OS VM resynchronizes its time to the Cisco IOS time. No user configuration is required to initiate Guest OS VM clock synchronization or to modify clock settings. You can configure Cisco IOS to synchronize to an external NTP server.

In config terminal, use the following commands:

ntp update-calendar
ntp server 10.64.58.50

Getting IOX Details

CGR1000#show iox host list detail

IOX Server is running. Process ID: 305
Count of hosts registered: 1

Host registered:
===============
    IOX Server Address: FE80::242:68FF:FEEA:D0CA; Port: 22222

    Link Local Address of Host: FE80::280:FFF:FE11:7000
    IPV4 Address of Host:       192.168.3.2
    IPV6 Address of Host:       fe80::280:fff:fe11:7000
    Client Version:             0.4
    Session ID:                 2
    OS Nodename:                CGM-SRV-64-4
    Host Hardware Vendor:       Cisco Systems, Inc.
    Host Hardware Version:      1.0
    Host Card Type:             not implemented
    Host OS Version:            0.14.0.1
    OS status:                  RUNNING

    Interface Hardware Vendor:  None
    Interface Hardware Version: None
    Interface Card Type:        None

    Applications Registered:
    =======================
    Count of applications registered by this host: 0

Download and Upgrade Server Module Image

You can copy the server module image to flash using http, tftp, or scp protocols. Then, run the server-module install command to upgrade the server module image.

CGR1000#server-module 4 install
flash:cgr1000-compute-1.2.5.1.SPA
Operation requires module reload, do you want to continue? [yes]:
 Installing image: /cgr1000-compute-1.2.5.1.SPA ........................... Done!

Verify the Host OS version after image upgrade.

CGR1000#show iox host list detail

IOX Server is running. Process ID: 305
Count of hosts registered: 1

Host registered:
===============
    IOX Server Address: FE80::242:68FF:FEEA:D0CA; Port: 22222

    Link Local Address of Host: FE80::280:FFF:FE11:7000
    IPV4 Address of Host:       192.168.3.2
    IPV6 Address of Host:       fe80::280:fff:fe11:7000
    Client Version:             0.4
    Session ID:                 3
    OS Nodename:                CGM-SRV-64-4
    Host Hardware Vendor:       Cisco Systems, Inc.
    Host Hardware Version:      1.0
    Host Card Type:             not implemented
    Host OS Version:            1.2.5.1
    OS status:                  RUNNING

    Interface Hardware Vendor:  None
    Interface Hardware Version: None
    Interface Card Type:        None

    Applications Registered:
    =======================
Count of applications registered by this host: 0